p PatchFirst

CVE-2015-8315

CVE-2015-8315

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

CVSS 7.5 · High · EPSS 7.0% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ms npm

    Affected ranges
    • SEMVER: < 0.7.1

    Update to 0.7.1

Original sources

Check your server →