p PatchFirst

CVE-2015-8338

CVE-2015-8338

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Xen 4.6.x and earlier does not properly enforce limits on page order inputs for the (1) XENMEM_increase_reservation, (2) XENMEM_populate_physmap, (3) XENMEM_exchange, and possibly other HYPERVISOR_memory_op suboperations, which allows ARM guest OS administrators to cause a denial of service (CPU consumption, guest reboot, or watchdog timeout and host reboot) and possibly have unspecified other impact via unknown vectors.

EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.8.0~rc3-1

    Update to 4.8.0~rc3-1

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.8.0~rc3-1

    Update to 4.8.0~rc3-1

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.8.0~rc3-1

    Update to 4.8.0~rc3-1

  • xen Ubuntu:14.04:LTS

    Versions
    • 4.3.0-1ubuntu1
    • 4.3.0-1ubuntu2
    • 4.3.0-1ubuntu3
    • 4.3.0-1ubuntu4
    • 4.3.0-1ubuntu5
    • 4.4.0-0ubuntu3
    • 4.4.0-0ubuntu4
    • 4.4.0-0ubuntu5
    • 4.4.0-0ubuntu5.1
    • 4.4.0-0ubuntu5.2
    • 4.4.1-0ubuntu0.14.04.1
    • 4.4.1-0ubuntu0.14.04.2
    • 4.4.1-0ubuntu0.14.04.3
    • 4.4.1-0ubuntu0.14.04.4
    • 4.4.1-0ubuntu0.14.04.5
    • 4.4.1-0ubuntu0.14.04.6
    • 4.4.2-0ubuntu0.14.04.1
    • 4.4.2-0ubuntu0.14.04.2
    • 4.4.2-0ubuntu0.14.04.3
    Affected ranges
    • ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.4

    Update to 4.4.2-0ubuntu0.14.04.4

Original sources

Check your server →