p PatchFirst

CVE-2015-8472

CVE-2015-8472

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Buffer overflow in the png_set_PLTE function in libpng before 1.0.65, 1.1.x and 1.2.x before 1.2.55, 1.3.x, 1.4.x before 1.4.18, 1.5.x before 1.5.25, and 1.6.x before 1.6.20 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8126.

CVSS 7.3 · High · EPSS 6.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libpng1.6 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.20-1

    Update to 1.6.20-1

  • libpng1.6 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.20-1

    Update to 1.6.20-1

  • libpng1.6 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.20-1

    Update to 1.6.20-1

  • libpng Ubuntu:14.04:LTS

    Versions
    • 1.2.49-4ubuntu1
    • 1.2.49-5ubuntu1
    • 1.2.50-1ubuntu1
    • 1.2.50-1ubuntu2
    • 1.2.50-1ubuntu2.14.04.1
    Affected ranges
    • ECOSYSTEM: < 1.2.50-1ubuntu2.14.04.2

    Update to 1.2.50-1ubuntu2.14.04.2

Original sources

Check your server →