p PatchFirst

CVE-2015-8622

CVE-2015-8622

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1, when is configured with a relative URL, allows remote authenticated users to inject arbitrary web script or HTML via wikitext, as demonstrated by a wikilink to a page named "javascript:alert('XSS!')."

CVSS 6.1 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

Original sources

Check your server →