p PatchFirst

CVE-2015-8626

CVE-2015-8626

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The User::randomPassword function in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 generates passwords smaller than $wgMinimalPasswordLength, which makes it easier for remote attackers to obtain access via a brute-force attack.

CVSS 9.8 · Critical · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.25.5-1

    Update to 1:1.25.5-1

Original sources

Check your server →