p PatchFirst

CVE-2015-8851

CVE-2015-8851

This page contains facts from public vulnerability sources. Check the original advisory before updating.

node-uuid before 1.4.4 uses insufficiently random data to create a GUID, which could make it easier for attackers to have unspecified impact via brute force guessing.

CVSS 7.5 · High · EPSS 2.3% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • node-uuid

    Versions
    • before 1.4.4: Affected

    No fix published

  • node-uuid Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.7-1

    Update to 1.4.7-1

  • node-uuid Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.7-1

    Update to 1.4.7-1

  • node-uuid Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.7-1

    Update to 1.4.7-1

  • node-uuid npm

    Affected ranges
    • SEMVER: < 1.4.4

    Update to 1.4.4

Original sources

Check your server →