CVE-2015-8854
CVE-2015-8854
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service (CPU consumption) via unspecified vectors that trigger a "catastrophic backtracking issue for the em inline rule," aka a "regular expression denial of service (ReDoS)."
CVSS 7.5 · High · EPSS 4.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-marked Debian:12
- Affected ranges
- ECOSYSTEM: < 0.3.6+dfsg-1
Update to 0.3.6+dfsg-1
node-marked Debian:13
- Affected ranges
- ECOSYSTEM: < 0.3.6+dfsg-1
Update to 0.3.6+dfsg-1
node-marked Debian:14
- Affected ranges
- ECOSYSTEM: < 0.3.6+dfsg-1
Update to 0.3.6+dfsg-1
marked npm
- Affected ranges
- SEMVER: < 0.3.4
Update to 0.3.4
node-marked Ubuntu:16.04:LTS
- Versions
- 0.3.2+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://nodesecurity.io/advisories/23
- http://www.openwall.com/lists/oss-security/2016/04/20/11
- https://support.f5.com/csp/article/K05052081?utm_source=f5support&%3Butm_medium=RSS
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S/
- https://nvd.nist.gov/vuln/detail/CVE-2015-8854