p PatchFirst

CVE-2015-9542

CVE-2015-9542

This page contains facts from public vulnerability sources. Check the original advisory before updating.

add_password in pam_radius_auth.c in pam_radius 1.4.0 does not correctly check the length of the input password, and is vulnerable to a stack-based buffer overflow during memcpy(). An attacker could send a crafted password to an application (loading the pam_radius library) and crash it. Arbitrary code execution might be possible, depending on the application, C library, compiler, and other factors.

CVSS 7.5 · High · EPSS 3.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libpam-radius-auth Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.0-3

    Update to 1.4.0-3

  • libpam-radius-auth Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.0-3

    Update to 1.4.0-3

  • libpam-radius-auth Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.0-3

    Update to 1.4.0-3

  • libpam-radius-auth Ubuntu:Pro:14.04:LTS

    Versions
    • 1.3.17-0ubuntu4
    Affected ranges
    • ECOSYSTEM: < 1.3.17-0ubuntu4+esm1

    Update to 1.3.17-0ubuntu4+esm1

  • libpam-radius-auth Ubuntu:16.04:LTS

    Versions
    • 1.3.17-0ubuntu4
    Affected ranges
    • ECOSYSTEM: < 1.3.17-0ubuntu4.1

    Update to 1.3.17-0ubuntu4.1

  • libpam-radius-auth Ubuntu:18.04:LTS

    Versions
    • 1.3.17-0ubuntu5
    Affected ranges
    • ECOSYSTEM: < 1.3.17-0ubuntu5.18.04.1

    Update to 1.3.17-0ubuntu5.18.04.1

Original sources

Check your server →