p PatchFirst

CVE-2016-0714

CVE-2016-0714

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

The session-persistence implementation in Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 mishandles session attributes, which allows remote authenticated users to bypass intended SecurityManager restrictions and execute arbitrary code in a privileged context via a web application that places a crafted object in a session.

CVSS 8.8 · High · EPSS 13.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • tomcat6 Ubuntu:14.04:LTS

    Versions
    • 6.0.37-1
    • 6.0.39-1
    Affected ranges
    • ECOSYSTEM: < 6.0.39-1ubuntu0.1

    Update to 6.0.39-1ubuntu0.1

  • tomcat7 Ubuntu:14.04:LTS

    Versions
    • 7.0.42-1
    • 7.0.47-1
    • 7.0.50-1
    • 7.0.52-1
    • 7.0.52-1ubuntu0.1
    • 7.0.52-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 7.0.52-1ubuntu0.6

    Update to 7.0.52-1ubuntu0.6

  • tomcat6 Ubuntu:16.04:LTS

    Versions
    • 6.0.41-4
    Affected ranges
    • ECOSYSTEM: < 6.0.45+dfsg-1

    Update to 6.0.45+dfsg-1

Original sources

Check your server →