p PatchFirst

CVE-2016-0724

CVE-2016-0724

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The (1) core_enrol_get_course_enrolment_methods and (2) enrol_self_get_instance_info web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.

CVSS 4.3 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v2.3.10
    • v2.3.11
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.3.8
    • v2.3.9
    • v2.4.0
    • v2.4.0-rc1
    • v2.4.1
    • v2.4.10
    • v2.4.11
    • v2.4.2
    • v2.4.3
    • v2.4.4
    • v2.4.5
    • v2.4.6
    • v2.4.7
    • v2.4.8
    • v2.4.9
    • v2.5.0
    • v2.5.0-beta
    • v2.5.0-rc1
    • v2.5.1
    • v2.5.2
    • v2.5.3
    • v2.5.4
    • v2.5.5
    • v2.5.6
    • v2.5.7
    • v2.5.8
    • v2.5.9
    • v2.6.0
    • v2.6.0-beta
    • v2.6.0-rc1
    • v2.6.1
    • v2.6.10
    • v2.6.11
    • v2.6.2
    • v2.6.3
    • v2.6.4
    • v2.6.5
    • v2.6.6
    • v2.6.7
    • v2.6.8
    • v2.6.9
    Affected ranges
    • ECOSYSTEM: ≤ 2.6.11

    No fix published

  • moodle/moodle Packagist

    Versions
    • v2.7.0
    • v2.7.1
    • v2.7.10
    • v2.7.11
    • v2.7.2
    • v2.7.3
    • v2.7.4
    • v2.7.5
    • v2.7.6
    • v2.7.7
    • v2.7.8
    • v2.7.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.0, < 2.7.12

    Update to 2.7.12

  • moodle/moodle Packagist

    Versions
    • v2.8.0
    • v2.8.1
    • v2.8.2
    • v2.8.3
    • v2.8.4
    • v2.8.5
    • v2.8.6
    • v2.8.7
    • v2.8.8
    • v2.8.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.8.0, < 2.8.10

    Update to 2.8.10

  • moodle/moodle Packagist

    Versions
    • v2.9.0
    • v2.9.1
    • v2.9.2
    • v2.9.3
    Affected ranges
    • ECOSYSTEM: ≥ 2.9.0, < 2.9.4

    Update to 2.9.4

  • moodle/moodle Packagist

    Versions
    • v3.0.0
    • v3.0.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.2

    Update to 3.0.2

Original sources

Check your server →