CVE-2016-0725
CVE-2016-0725
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.
CVSS 6.1 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.8.0
- v2.8.0-beta
- v2.8.0-rc1
- v2.8.0-rc2
- v2.8.1
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v2.8.9
- Affected ranges
- ECOSYSTEM: ≥ 2.8, < 2.8.10
Update to 2.8.10
moodle/moodle Packagist
- Versions
- v2.9.0
- v2.9.0-beta
- v2.9.0-rc1
- v2.9.0-rc2
- v2.9.1
- v2.9.2
- v2.9.3
- Affected ranges
- ECOSYSTEM: ≥ 2.9, < 2.9.4
Update to 2.9.4
moodle/moodle Packagist
- Versions
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- Affected ranges
- ECOSYSTEM: ≥ 3.0, < 3.0.2
Update to 3.0.2
Original sources
- http://www.securitytracker.com/id/1034694
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-52552
- https://moodle.org/mod/forum/discuss.php?d=326206
- http://www.openwall.com/lists/oss-security/2016/01/18/1
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176502.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-January/176436.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-0725