p PatchFirst

CVE-2016-0755

CVE-2016-0755

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The ConnectionExists function in lib/url.c in libcurl before 7.47.0 does not properly re-use NTLM-authenticated proxy connections, which might allow remote attackers to authenticate as other users via a request, a similar issue to CVE-2014-0015.

CVSS 7.3 · High · EPSS 9.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.47.0-1

    Update to 7.47.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.47.0-1

    Update to 7.47.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.47.0-1

    Update to 7.47.0-1

  • curl Ubuntu:14.04:LTS

    Versions
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 7.35.0-1ubuntu2.6

    Update to 7.35.0-1ubuntu2.6

Original sources

Check your server →