p PatchFirst

CVE-2016-0775

CVE-2016-0775

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in the ImagingFliDecode function in libImaging/FliDecode.c in Pillow before 3.1.1 allows remote attackers to cause a denial of service (crash) via a crafted FLI file.

CVSS 7.1 · High · EPSS 2.5% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pillow Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.1.1-1

    Update to 3.1.1-1

  • pillow Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.1.1-1

    Update to 3.1.1-1

  • pillow Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.1.1-1

    Update to 3.1.1-1

  • pillow PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.7.0
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.9.0
    • 3.0.0
    • 3.1.0
    • 3.1.0.rc1
    • 3.1.0rc1
    Affected ranges
    • ECOSYSTEM: < 3.1.1

    Update to 3.1.1

  • pillow PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.7.0
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.9.0
    • 3.0.0
    • 3.1.0
    • 3.1.0.rc1
    • 3.1.0rc1
    Affected ranges
    • GIT: < 893a40850c2d5da41537958e40569c029a6e127b
    • ECOSYSTEM: < 3.1.1

    Update to 3.1.1

  • pillow Ubuntu:14.04:LTS

    Versions
    • 2.2.1-1ubuntu2
    • 2.2.1-2ubuntu1
    • 2.2.1-3ubuntu2
    • 2.2.1-3ubuntu3
    • 2.2.1-3ubuntu4
    • 2.2.1-3ubuntu6
    • 2.3.0-1ubuntu1
    • 2.3.0-1ubuntu2
    • 2.3.0-1ubuntu3
    Affected ranges
    • ECOSYSTEM: < 2.3.0-1ubuntu3.2

    Update to 2.3.0-1ubuntu3.2

Original sources

Check your server →