p PatchFirst

CVE-2016-1000030

CVE-2016-1000030

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and gnutls_x509_crt_import() that can result in code execution. This attack appear to be exploitable via custom X.509 certificate from another client. This vulnerability appears to have been fixed in 2.11.0.

CVSS 9.8 · Critical · EPSS 1.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pidgin Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

  • pidgin Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

  • pidgin Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

Original sources

Check your server →