CVE-2016-1000108
CVE-2016-1000108
This page contains facts from public vulnerability sources. Check the original advisory before updating.
yaws before 2.0.4 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
CVSS 6.1 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
yaws Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.3-2
Update to 2.0.3-2
yaws Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.3-2
Update to 2.0.3-2
yaws Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.3-2
Update to 2.0.3-2
yaws Ubuntu:16.04:LTS
- Versions
- 1.98-5
- 1.99-1
- 1.99-2
- 2.0.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://raw.githubusercontent.com/distributedweaknessfiling/cvelist/master/2016/1000xxx/CVE-2016-1000108.json
- http://www.openwall.com/lists/oss-security/2016/07/18/6
- https://security-tracker.debian.org/tracker/CVE-2016-1000108
- https://github.com/klacke/yaws/commit/9d8fb070e782c95821c90d0ca7372fc6d7316c78#diff-54053c47eb173a90c26ed19bd9d106c1
- https://nvd.nist.gov/vuln/detail/CVE-2016-1000108