CVE-2016-10068
CVE-2016-10068
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The MSL interpreter in ImageMagick before 6.9.6-4 allows remote attackers to cause a denial of service (segmentation fault and application crash) via a crafted XML file.
CVSS 5.5 · Medium · EPSS 2.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.5+dfsg-1
Update to 8:6.9.6.5+dfsg-1
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.5+dfsg-1
Update to 8:6.9.6.5+dfsg-1
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.5+dfsg-1
Update to 8:6.9.6.5+dfsg-1
imagemagick Ubuntu:14.04:LTS
- Versions
- 8:6.7.7.10-5ubuntu3
- 8:6.7.7.10-5ubuntu4
- 8:6.7.7.10-6ubuntu1
- 8:6.7.7.10-6ubuntu2
- 8:6.7.7.10-6ubuntu3
- 8:6.7.7.10-6ubuntu3.1
- 8:6.7.7.10-6ubuntu3.2
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.3
Update to 8:6.7.7.10-6ubuntu3.3
imagemagick Ubuntu:16.04:LTS
- Versions
- 8:6.8.9.9-5ubuntu2
- 8:6.8.9.9-6
- 8:6.8.9.9-6build1
- 8:6.8.9.9-7
- 8:6.8.9.9-7ubuntu1
- 8:6.8.9.9-7ubuntu2
- 8:6.8.9.9-7ubuntu3
- 8:6.8.9.9-7ubuntu4
- 8:6.8.9.9-7ubuntu5
- 8:6.8.9.9-7ubuntu5.1
- 8:6.8.9.9-7ubuntu5.2
- Affected ranges
- ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.3
Update to 8:6.8.9.9-7ubuntu5.3
Original sources
- http://www.securityfocus.com/bid/95219
- http://lists.opensuse.org/opensuse-updates/2017-02/msg00028.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1410500
- https://github.com/ImageMagick/ImageMagick/commit/56d6e20de489113617cbbddaf41e92600a34db22
- http://lists.opensuse.org/opensuse-updates/2017-02/msg00031.html
- http://www.openwall.com/lists/oss-security/2016/12/26/9
- https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=30797
- https://nvd.nist.gov/vuln/detail/CVE-2016-10068