p PatchFirst

CVE-2016-10074

CVE-2016-10074

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The mail transport (aka Swift_Transport_MailTransport) in Swift Mailer before 5.4.5 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted e-mail address in the (1) From, (2) ReturnPath, or (3) Sender header.

CVSS 9.8 · Critical · EPSS 43.8% · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-swiftmailer Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.4.2-1.1

    Update to 5.4.2-1.1

  • libphp-swiftmailer Debian:14

    Versions
    • 4.0.6-1
    • 4.1.0-1
    • 4.1.0-2
    • 4.1.2-1
    • 4.1.3-1
    • 4.1.5-1
    • 4.1.5-1~bpo60+1
    • 4.2.0-1
    • 4.2.1-1
    • 5.2.1-1
    • 5.2.2-1
    • 5.4.1-1
    • 5.4.2-1
    Affected ranges
    • ECOSYSTEM: < 5.4.2-1.1

    Update to 5.4.2-1.1

  • swiftmailer/swiftmailer Packagist

    Versions
    • 4.1.3
    • 4.1.4
    • 4.1.5
    • 4.1.6
    • 4.1.7
    • v4.1.8
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.3.0
    • v4.3.1
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.1.0
    • v5.2.0
    • v5.2.1
    • v5.2.2
    • v5.3.0
    • v5.3.1
    • v5.4.0
    • v5.4.1
    • v5.4.2
    • v5.4.3
    • v5.4.4
    Affected ranges
    • ECOSYSTEM: < 5.4.5

    Update to 5.4.5

  • libphp-swiftmailer Ubuntu:Pro:16.04:LTS

    Versions
    • 5.4.1-1
    • 5.4.1-1ubuntu1
    • 5.4.1-1ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libphp-swiftmailer Ubuntu:18.04:LTS

    Affected ranges
    • ECOSYSTEM: < 5.4.2-1.1

    Update to 5.4.2-1.1

  • libphp-swiftmailer Ubuntu:20.04:LTS

    Affected ranges
    • ECOSYSTEM: < 5.4.2-1.1

    Update to 5.4.2-1.1

Original sources

Check your server →