CVE-2016-10148
CVE-2016-10148
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress before 4.6 makes a get_plugin_data call before checking the update_plugins capability, which allows remote authenticated users to bypass intended read-access restrictions via the plugin parameter to wp-admin/admin-ajax.php, a related issue to CVE-2016-6896.
CVSS 4.3 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.6.1+dfsg-1
Update to 4.6.1+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.6.1+dfsg-1
Update to 4.6.1+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.6.1+dfsg-1
Update to 4.6.1+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/96847
- http://www.openwall.com/lists/oss-security/2016/08/20/1
- https://core.trac.wordpress.org/changeset/38168
- https://sumofpwn.nl/advisory/2016/path_traversal_vulnerability_in_wordpress_core_ajax_handlers.html
- https://core.trac.wordpress.org/ticket/37490
- https://nvd.nist.gov/vuln/detail/CVE-2016-10148