CVE-2016-10190
CVE-2016-10190
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote web servers to execute arbitrary code via a negative chunk size in an HTTP response.
CVSS 9.8 · Critical · EPSS 8.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ffmpeg Debian:12
- Affected ranges
- ECOSYSTEM: < 7:3.2.2-1
Update to 7:3.2.2-1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 7:3.2.2-1
Update to 7:3.2.2-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 7:3.2.2-1
Update to 7:3.2.2-1
libav Ubuntu:Pro:14.04:LTS
- Versions
- 6:0.8.7-1ubuntu2
- 6:9.10-1ubuntu1
- 6:9.10-1ubuntu2
- 6:9.10-1ubuntu5
- 6:9.10-1ubuntu6
- 6:9.10-1ubuntu7
- 6:9.11-2ubuntu1
- 6:9.11-2ubuntu2
- 6:9.13-0ubuntu0.14.04.1
- 6:9.14-0ubuntu0.14.04.1
- 6:9.16-0ubuntu0.14.04.1
- 6:9.18-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ffmpeg Ubuntu:16.04:LTS
- Versions
- 7:2.7.2-1build1
- 7:2.8.1-1ubuntu1
- 7:2.8.2-1ubuntu1
- 7:2.8.3-1
- 7:2.8.4-1
- 7:2.8.4-1ubuntu1
- 7:2.8.4-1ubuntu2
- 7:2.8.4-1ubuntu3
- 7:2.8.4-1ubuntu4
- 7:2.8.6-1ubuntu1
- 7:2.8.6-1ubuntu2
- 7:2.8.8-0ubuntu0.16.04.1
- 7:2.8.10-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 7:2.8.11-0ubuntu0.16.04.1
Update to 7:2.8.11-0ubuntu0.16.04.1
Original sources
- https://lists.debian.org/debian-lts-announce/2018/12/msg00009.html
- http://www.openwall.com/lists/oss-security/2017/01/31/12
- http://www.openwall.com/lists/oss-security/2017/02/02/1
- https://github.com/FFmpeg/FFmpeg/commit/2a05c8f813de6f2278827734bf8102291e7484aa
- https://trac.ffmpeg.org/ticket/5992
- http://www.securityfocus.com/bid/95986
- https://ffmpeg.org/security.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-10190