CVE-2016-10228
CVE-2016-10228
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.
CVSS 5.9 · Medium · EPSS 4.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
glibc Debian:12
- Affected ranges
- ECOSYSTEM: < 2.31-3
Update to 2.31-3
glibc Debian:13
- Affected ranges
- ECOSYSTEM: < 2.31-3
Update to 2.31-3
glibc Debian:14
- Affected ranges
- ECOSYSTEM: < 2.31-3
Update to 2.31-3
eglibc Ubuntu:Pro:14.04:LTS
- Versions
- 2.17-93ubuntu4
- 2.18-0ubuntu1
- 2.18-0ubuntu2
- 2.18-0ubuntu4
- 2.18-0ubuntu5
- 2.18-0ubuntu6
- 2.18-0ubuntu7
- 2.19-0ubuntu2
- 2.19-0ubuntu3
- 2.19-0ubuntu4
- 2.19-0ubuntu5
- 2.19-0ubuntu6
- 2.19-0ubuntu6.1
- 2.19-0ubuntu6.3
- 2.19-0ubuntu6.4
- 2.19-0ubuntu6.5
- 2.19-0ubuntu6.6
- 2.19-0ubuntu6.7
- 2.19-0ubuntu6.8
- 2.19-0ubuntu6.9
- 2.19-0ubuntu6.10
- 2.19-0ubuntu6.11
- 2.19-0ubuntu6.13
- 2.19-0ubuntu6.14
- 2.19-0ubuntu6.15
- 2.19-0ubuntu6.15+esm1
- 2.19-0ubuntu6.15+esm2
- 2.19-0ubuntu6.15+esm3
- 2.19-0ubuntu6.15+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
glibc Ubuntu:Pro:16.04:LTS
- Versions
- 2.21-0ubuntu4
- 2.21-0ubuntu5
- 2.21-0ubuntu6
- 2.23-0ubuntu1
- 2.23-0ubuntu2
- 2.23-0ubuntu3
- 2.23-0ubuntu4
- 2.23-0ubuntu5
- 2.23-0ubuntu6
- 2.23-0ubuntu7
- 2.23-0ubuntu9
- 2.23-0ubuntu10
- 2.23-0ubuntu11
- 2.23-0ubuntu11.2
- 2.23-0ubuntu11.3
- 2.23-0ubuntu11.3+esm1
- 2.23-0ubuntu11.3+esm2
- Affected ranges
- ECOSYSTEM: < 2.23-0ubuntu11.3+esm3
Update to 2.23-0ubuntu11.3+esm3
glibc Ubuntu:18.04:LTS
- Versions
- 2.26-0ubuntu2
- 2.26-0ubuntu2.1
- 2.27-0ubuntu2
- 2.27-0ubuntu3
- 2.27-3ubuntu1
- 2.27-3ubuntu1.2
- 2.27-3ubuntu1.3
- 2.27-3ubuntu1.4
- Affected ranges
- ECOSYSTEM: < 2.27-3ubuntu1.5
Update to 2.27-3ubuntu1.5
glibc Ubuntu:20.04:LTS
- Versions
- 2.30-0ubuntu2
- 2.30-0ubuntu3
- 2.31-0ubuntu5
- 2.31-0ubuntu6
- 2.31-0ubuntu7
- 2.31-0ubuntu9
- 2.31-0ubuntu9.1
- 2.31-0ubuntu9.2
- 2.31-0ubuntu9.3
- Affected ranges
- ECOSYSTEM: < 2.31-0ubuntu9.7
Update to 2.31-0ubuntu9.7
Original sources
- http://www.securityfocus.com/bid/96525
- https://security.gentoo.org/glsa/202101-20
- https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://sourceware.org/bugzilla/show_bug.cgi?id=19519
- http://openwall.com/lists/oss-security/2017/03/01/10
- https://sourceware.org/bugzilla/show_bug.cgi?id=19519#c21
- https://sourceware.org/bugzilla/show_bug.cgi?id=26224
- https://lists.debian.org/debian-lts-announce/2022/10/msg00021.html
- https://cert-portal.siemens.com/productcert/html/ssa-831302.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-10228