p PatchFirst

CVE-2016-10321

CVE-2016-10321

This page contains facts from public vulnerability sources. Check the original advisory before updating.

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

CVSS 9.8 · Critical · EPSS 2.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • web2py PyPI

    Versions
    • 1.96.4
    • 1.98.2
    • 2.1.1
    Affected ranges
    • ECOSYSTEM: < 2.14.6

    Update to 2.14.6

  • web2py Ubuntu:16.04:LTS

    Versions
    • 1.99.7-1
    • 2.12.3-1
    Affected ranges
    • ECOSYSTEM: < 2.12.3-1ubuntu0.1

    Update to 2.12.3-1ubuntu0.1

Original sources

Check your server →