CVE-2016-10542
CVE-2016-10542
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ws is a "simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455". By sending an overly long websocket payload to a `ws` server, it is possible to crash the node process. This affects ws 1.1.0 and earlier.
CVSS 7.5 · High · EPSS 7.4% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
ws node module
- Versions
- <=1.1.0: Affected
No fix published
node-ws Debian:12
- Affected ranges
- ECOSYSTEM: < 1.1.0+ds1.e6ddaae4-5
Update to 1.1.0+ds1.e6ddaae4-5
node-ws Debian:13
- Affected ranges
- ECOSYSTEM: < 1.1.0+ds1.e6ddaae4-5
Update to 1.1.0+ds1.e6ddaae4-5
node-ws Debian:14
- Affected ranges
- ECOSYSTEM: < 1.1.0+ds1.e6ddaae4-5
Update to 1.1.0+ds1.e6ddaae4-5
ws npm
- Affected ranges
- SEMVER: < 1.1.1
Update to 1.1.1
node-ws Ubuntu:16.04:LTS
- Versions
- 0.7.2+ds1.349b7460-1
- 1.0.1+ds1.e6ddaae4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ws Ubuntu:18.04:LTS
- Versions
- 1.1.0+ds1.e6ddaae4-3build1
- 1.1.0+ds1.e6ddaae4-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published