CVE-2016-10739
CVE-2016-10739
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.
CVSS 5.3 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
glibc Debian:12
- Affected ranges
- ECOSYSTEM: < 2.28-6
Update to 2.28-6
glibc Debian:13
- Affected ranges
- ECOSYSTEM: < 2.28-6
Update to 2.28-6
glibc Debian:14
- Affected ranges
- ECOSYSTEM: < 2.28-6
Update to 2.28-6
eglibc Ubuntu:Pro:14.04:LTS
- Versions
- 2.17-93ubuntu4
- 2.18-0ubuntu1
- 2.18-0ubuntu2
- 2.18-0ubuntu4
- 2.18-0ubuntu5
- 2.18-0ubuntu6
- 2.18-0ubuntu7
- 2.19-0ubuntu2
- 2.19-0ubuntu3
- 2.19-0ubuntu4
- 2.19-0ubuntu5
- 2.19-0ubuntu6
- 2.19-0ubuntu6.1
- 2.19-0ubuntu6.3
- 2.19-0ubuntu6.4
- 2.19-0ubuntu6.5
- 2.19-0ubuntu6.6
- 2.19-0ubuntu6.7
- 2.19-0ubuntu6.8
- 2.19-0ubuntu6.9
- 2.19-0ubuntu6.10
- 2.19-0ubuntu6.11
- 2.19-0ubuntu6.13
- 2.19-0ubuntu6.14
- 2.19-0ubuntu6.15
- 2.19-0ubuntu6.15+esm1
- 2.19-0ubuntu6.15+esm2
- 2.19-0ubuntu6.15+esm3
- 2.19-0ubuntu6.15+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
glibc Ubuntu:Pro:16.04:LTS
- Versions
- 2.21-0ubuntu4
- 2.21-0ubuntu5
- 2.21-0ubuntu6
- 2.23-0ubuntu1
- 2.23-0ubuntu2
- 2.23-0ubuntu3
- 2.23-0ubuntu4
- 2.23-0ubuntu5
- 2.23-0ubuntu6
- 2.23-0ubuntu7
- 2.23-0ubuntu9
- 2.23-0ubuntu10
- 2.23-0ubuntu11
- 2.23-0ubuntu11.2
- 2.23-0ubuntu11.3
- 2.23-0ubuntu11.3+esm1
- 2.23-0ubuntu11.3+esm2
- 2.23-0ubuntu11.3+esm3
- 2.23-0ubuntu11.3+esm5
- 2.23-0ubuntu11.3+esm6
- 2.23-0ubuntu11.3+esm7
- 2.23-0ubuntu11.3+esm8
- 2.23-0ubuntu11.3+esm9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
glibc Ubuntu:Pro:18.04:LTS
- Versions
- 2.26-0ubuntu2
- 2.26-0ubuntu2.1
- 2.27-0ubuntu2
- 2.27-0ubuntu3
- 2.27-3ubuntu1
- 2.27-3ubuntu1.2
- 2.27-3ubuntu1.3
- 2.27-3ubuntu1.4
- 2.27-3ubuntu1.5
- 2.27-3ubuntu1.6
- 2.27-3ubuntu1.6+esm1
- 2.27-3ubuntu1.6+esm2
- 2.27-3ubuntu1.6+esm3
- 2.27-3ubuntu1.6+esm4
- 2.27-3ubuntu1.6+esm5
- 2.27-3ubuntu1.6+esm6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://sourceware.org/bugzilla/show_bug.cgi?id=20018
- http://www.securityfocus.com/bid/106672
- https://bugzilla.redhat.com/show_bug.cgi?id=1347549
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00082.html
- https://access.redhat.com/errata/RHSA-2019:2118
- https://access.redhat.com/errata/RHSA-2019:3513
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-10739