CVE-2016-1570
CVE-2016-1570
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The PV superpage functionality in arch/x86/mm.c in Xen 3.4.0, 3.4.1, and 4.1.x through 4.6.x allows local PV guests to obtain sensitive information, cause a denial of service, gain privileges, or have unspecified other impact via a crafted page identifier (MFN) to the (1) MMUEXT_MARK_SUPER or (2) MMUEXT_UNMARK_SUPER sub-op in the HYPERVISOR_mmuext_op hypercall or (3) unknown vectors related to page table updates.
CVSS 8.5 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.0~rc3-1
Update to 4.8.0~rc3-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.0~rc3-1
Update to 4.8.0~rc3-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.0~rc3-1
Update to 4.8.0~rc3-1
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- 4.4.1-0ubuntu0.14.04.5
- 4.4.1-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.1
- 4.4.2-0ubuntu0.14.04.2
- 4.4.2-0ubuntu0.14.04.3
- 4.4.2-0ubuntu0.14.04.4
- Affected ranges
- ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.5
Update to 4.4.2-0ubuntu0.14.04.5