p PatchFirst

CVE-2016-1626

CVE-2016-1626

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The opj_pi_update_decode_poc function in pi.c in OpenJPEG, as used in PDFium in Google Chrome before 48.0.2564.109, miscalculates a certain layer index value, which allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted PDF document.

CVSS 4.3 · Medium · EPSS 1.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openjpeg2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.1.2-1.2

    Update to 2.1.2-1.2

  • openjpeg2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.1.2-1.2

    Update to 2.1.2-1.2

  • openjpeg2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.1.2-1.2

    Update to 2.1.2-1.2

  • chromium-browser Ubuntu:14.04:LTS

    Versions
    • 29.0.1547.65-0ubuntu2
    • 31.0.1650.63-0ubuntu1~20131204.1
    • 32.0.1700.107-0ubuntu1~20140204.977.1
    • 33.0.1750.152-0ubuntu1~pkg995.1
    • 34.0.1847.116-0ubuntu2
    • 36.0.1985.125-0ubuntu1.14.04.0~pkg1029
    • 37.0.2062.94-0ubuntu0.14.04.1~pkg1042
    • 37.0.2062.120-0ubuntu0.14.04.1~pkg1049
    • 38.0.2125.111-0ubuntu0.14.04.1.1061
    • 39.0.2171.65-0ubuntu0.14.04.1.1064
    • 40.0.2214.94-0ubuntu0.14.04.1.1068
    • 40.0.2214.111-0ubuntu0.14.04.1.1069
    • 41.0.2272.76-0ubuntu0.14.04.1.1076
    • 43.0.2357.81-0ubuntu0.14.04.1.1089
    • 43.0.2357.130-0ubuntu0.14.04.1.1092
    • 44.0.2403.89-0ubuntu0.14.04.1.1095
    • 45.0.2454.85-0ubuntu0.14.04.1.1097
    • 45.0.2454.101-0ubuntu0.14.04.1.1099
    • 47.0.2526.73-0ubuntu0.14.04.1.1106
    • 47.0.2526.106-0ubuntu0.14.04.1.1107
    • 48.0.2564.82-0ubuntu0.14.04.1.1108
    Affected ranges
    • ECOSYSTEM: < 48.0.2564.116-0ubuntu0.14.04.1.1111

    Update to 48.0.2564.116-0ubuntu0.14.04.1.1111

Original sources

Check your server →