p PatchFirst

CVE-2016-2098

CVE-2016-2098

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Action Pack in Ruby on Rails before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2 allows remote attackers to execute arbitrary Ruby code by leveraging an application's unrestricted use of the render method.

CVSS 7.3 · High · EPSS 81.4% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.2.5.2-1

    Update to 2:4.2.5.2-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.2.5.2-1

    Update to 2:4.2.5.2-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.2.5.2-1

    Update to 2:4.2.5.2-1

Original sources

Check your server →