CVE-2016-2114
CVE-2016-2114
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
The SMB1 protocol implementation in Samba 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not recognize the "server signing = mandatory" setting, which allows man-in-the-middle attackers to spoof SMB servers by modifying the client-server data stream.
CVSS 5.9 · Medium · EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- Affected ranges
- ECOSYSTEM: < 2:4.3.8+dfsg-0ubuntu0.14.04.2
Update to 2:4.3.8+dfsg-0ubuntu0.14.04.2
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2:4.3.8+dfsg-0ubuntu1
Update to 2:4.3.8+dfsg-0ubuntu1
Original sources
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.458012
- http://rhn.redhat.com/errata/RHSA-2016-0612.html
- http://www.ubuntu.com/usn/USN-2950-1
- http://www.securityfocus.com/bid/86011
- http://badlock.org/
- https://www.samba.org/samba/security/CVE-2016-2114.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://www.ubuntu.com/usn/USN-2950-5
- https://www.samba.org/samba/history/samba-4.2.10.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182185.html
- http://rhn.redhat.com/errata/RHSA-2016-0618.html
- https://www.samba.org/samba/latest_news.html#4.4.2
- http://www.securitytracker.com/id/1035533
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182272.html
- http://rhn.redhat.com/errata/RHSA-2016-0614.html
- http://rhn.redhat.com/errata/RHSA-2016-0620.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00047.html
- https://bto.bluecoat.com/security-advisory/sa122
- http://www.ubuntu.com/usn/USN-2950-3
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182288.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00048.html
- https://security.gentoo.org/glsa/201612-47
- http://www.debian.org/security/2016/dsa-3548
- https://nvd.nist.gov/vuln/detail/CVE-2016-2114