CVE-2016-2118
CVE-2016-2118
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
The MS-SAMR and MS-LSAD protocol implementations in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 mishandle DCERPC connections, which allows man-in-the-middle attackers to perform protocol-downgrade attacks and impersonate users by modifying the client-server data stream, aka "BADLOCK."
CVSS 7.5 · High · EPSS 37.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.3.7+dfsg-1
Update to 2:4.3.7+dfsg-1
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- Affected ranges
- ECOSYSTEM: < 2:4.3.8+dfsg-0ubuntu0.14.04.2
Update to 2:4.3.8+dfsg-0ubuntu0.14.04.2
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2:4.3.8+dfsg-0ubuntu1
Update to 2:4.3.8+dfsg-0ubuntu1
Original sources
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.458012
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00020.html
- http://rhn.redhat.com/errata/RHSA-2016-0612.html
- http://www.ubuntu.com/usn/USN-2950-1
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05166182
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00024.html
- http://rhn.redhat.com/errata/RHSA-2016-0613.html
- http://badlock.org/
- http://rhn.redhat.com/errata/RHSA-2016-0621.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00042.html
- http://www.ubuntu.com/usn/USN-2950-5
- https://www.samba.org/samba/history/samba-4.2.10.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182185.html
- http://rhn.redhat.com/errata/RHSA-2016-0624.html
- http://rhn.redhat.com/errata/RHSA-2016-0618.html
- http://www.securityfocus.com/bid/86002
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00021.html
- https://www.samba.org/samba/security/CVE-2016-2118.html
- https://www.samba.org/samba/latest_news.html#4.4.2
- http://www.securitytracker.com/id/1035533
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182272.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-2118