CVE-2016-2120
CVE-2016-2120
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0.1 allowing an authorized user to crash the server by inserting a specially crafted record in a zone under their control then sending a DNS query for that record. The issue is due to an integer overflow when checking if the content of the record matches the expected size, allowing an attacker to cause a read past the buffer boundary.
CVSS 7.5 · High · EPSS 2.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
pdns
- Versions
- up to and including 3.4.10: Affected
- up to and including 4.0.1: Affected
No fix published
pdns Debian:12
- Affected ranges
- ECOSYSTEM: < 4.0.2-1
Update to 4.0.2-1
pdns Debian:13
- Affected ranges
- ECOSYSTEM: < 4.0.2-1
Update to 4.0.2-1
pdns Debian:14
- Affected ranges
- ECOSYSTEM: < 4.0.2-1
Update to 4.0.2-1
pdns Ubuntu:Pro:16.04:LTS
- Versions
- 3.4.5-1build2
- 3.4.6-2
- 3.4.6-3
- 3.4.7-1
- 3.4.7-2
- 4.0.0~alpha1-1
- 4.0.0~alpha2-2
- 4.0.0~alpha2-3
- 4.0.0~alpha2-3build1
- 4.0.0~alpha2-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published