CVE-2016-2198
CVE-2016-2198
This page contains facts from public vulnerability sources. Check the original advisory before updating.
QEMU (aka Quick Emulator) built with the USB EHCI emulation support is vulnerable to a null pointer dereference flaw. It could occur when an application attempts to write to EHCI capabilities registers. A privileged user inside quest could use this flaw to crash the QEMU process instance resulting in DoS.
CVSS 5.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-1
Update to 1:2.6+dfsg-1
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-1
Update to 1:2.6+dfsg-1
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-1
Update to 1:2.6+dfsg-1
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- 2.0.0+dfsg-2ubuntu1.13
- 2.0.0+dfsg-2ubuntu1.14
- 2.0.0+dfsg-2ubuntu1.15
- 2.0.0+dfsg-2ubuntu1.16
- 2.0.0+dfsg-2ubuntu1.17
- 2.0.0+dfsg-2ubuntu1.18
- 2.0.0+dfsg-2ubuntu1.19
- 2.0.0+dfsg-2ubuntu1.20
- 2.0.0+dfsg-2ubuntu1.21
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.22
Update to 2.0.0+dfsg-2ubuntu1.22
Original sources
- http://www.openwall.com/lists/oss-security/2016/01/30/2
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1301643
- http://www.openwall.com/lists/oss-security/2016/01/29/6
- https://security.gentoo.org/glsa/201604-01
- https://lists.gnu.org/archive/html/qemu-devel/2016-01/msg05899.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-2198