p PatchFirst

CVE-2016-2222

CVE-2016-2222

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The wp_http_validate_url function in wp-includes/http.php in WordPress before 4.4.2 allows remote attackers to conduct server-side request forgery (SSRF) attacks via a zero value in the first octet of an IPv4 address in the u parameter to wp-admin/press-this.php.

CVSS 8.6 · High · EPSS 7.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.4.2+dfsg-1

    Update to 4.4.2+dfsg-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.4.2+dfsg-1

    Update to 4.4.2+dfsg-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.4.2+dfsg-1

    Update to 4.4.2+dfsg-1

Original sources

Check your server →