p PatchFirst

CVE-2016-2317

CVE-2016-2317

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple buffer overflows in GraphicsMagick 1.3.23 allow remote attackers to cause a denial of service (crash) via a crafted SVG file, related to the (1) TracePoint function in magick/render.c, (2) GetToken function in magick/utility.c, and (3) GetTransformTokens function in coders/svg.c.

CVSS 5.5 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • graphicsmagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • graphicsmagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • graphicsmagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • graphicsmagick Ubuntu:14.04:LTS

    Versions
    • 1.3.16-1.1ubuntu2
    • 1.3.16-1.1ubuntu3
    • 1.3.18-1ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.3.18-1ubuntu3.1

    Update to 1.3.18-1ubuntu3.1

  • graphicsmagick Ubuntu:16.04:LTS

    Versions
    • 1.3.21-3
    • 1.3.23-1
    • 1.3.23-1build1
    Affected ranges
    • ECOSYSTEM: < 1.3.23-1ubuntu0.1

    Update to 1.3.23-1ubuntu0.1

Original sources

Check your server →