CVE-2016-2327
CVE-2016-2327
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libavcodec/pngenc.c in FFmpeg before 2.8.5 uses incorrect line sizes in certain row calculations, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via a crafted .avi file, related to the apng_encode_frame and encode_apng functions.
CVSS 8.8 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ffmpeg Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.5-1
Update to 2.8.5-1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.5-1
Update to 2.8.5-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.5-1
Update to 2.8.5-1
ffmpeg Ubuntu:16.04:LTS
- Versions
- 7:2.7.2-1build1
- 7:2.8.1-1ubuntu1
- 7:2.8.2-1ubuntu1
- 7:2.8.3-1
- 7:2.8.4-1
- 7:2.8.4-1ubuntu1
- 7:2.8.4-1ubuntu2
- 7:2.8.4-1ubuntu3
- 7:2.8.4-1ubuntu4
- Affected ranges
- ECOSYSTEM: < 7:2.8.6-1ubuntu1
Update to 7:2.8.6-1ubuntu1
Original sources
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=7ec9c5ce8a753175244da971fed9f1e25aef7971
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=8f4c3e4b92212d98f5b9ca2dee13e076effe9589
- http://www.securitytracker.com/id/1035010
- https://security.gentoo.org/glsa/201606-09
- https://nvd.nist.gov/vuln/detail/CVE-2016-2327