CVE-2016-2328
CVE-2016-2328
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libswscale/swscale_unscaled.c in FFmpeg before 2.8.6 does not validate certain height values, which allows remote attackers to cause a denial of service (out-of-bounds array read access) or possibly have unspecified other impact via a crafted .cine file, related to the bayer_to_rgb24_wrapper and bayer_to_yv12_wrapper functions.
CVSS 8.8 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ffmpeg Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.6-1
Update to 2.8.6-1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.6-1
Update to 2.8.6-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.6-1
Update to 2.8.6-1
ffmpeg Ubuntu:16.04:LTS
- Versions
- 7:2.7.2-1build1
- 7:2.8.1-1ubuntu1
- 7:2.8.2-1ubuntu1
- 7:2.8.3-1
- 7:2.8.4-1
- 7:2.8.4-1ubuntu1
- 7:2.8.4-1ubuntu2
- 7:2.8.4-1ubuntu3
- 7:2.8.4-1ubuntu4
- Affected ranges
- ECOSYSTEM: < 7:2.8.6-1ubuntu1
Update to 7:2.8.6-1ubuntu1
Original sources
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=ad3b6fa7d83db7de951ed891649af93a47e74be5
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=757248ea3cd917a7755cb15f817a9b1f15578718
- http://www.securitytracker.com/id/1035010
- https://security.gentoo.org/glsa/201606-09
- https://nvd.nist.gov/vuln/detail/CVE-2016-2328