CVE-2016-2374
CVE-2016-2374
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable memory corruption vulnerability exists in the handling of the MXIT protocol in Pidgin. Specially crafted MXIT MultiMX message sent via the server can result in an out-of-bounds write leading to memory disclosure and code execution.
CVSS 8.1 · High · EPSS 3.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
pidgin
- Versions
- 2.10.11: Affected
No fix published
pidgin Debian:12
- Affected ranges
- ECOSYSTEM: < 2.11.0-1
Update to 2.11.0-1
pidgin Debian:13
- Affected ranges
- ECOSYSTEM: < 2.11.0-1
Update to 2.11.0-1
pidgin Debian:14
- Affected ranges
- ECOSYSTEM: < 2.11.0-1
Update to 2.11.0-1
pidgin Ubuntu:14.04:LTS
- Versions
- 1:2.10.7-0ubuntu4.1
- 1:2.10.7-0ubuntu4.2
- 1:2.10.9-0ubuntu1
- 1:2.10.9-0ubuntu2
- 1:2.10.9-0ubuntu3
- 1:2.10.9-0ubuntu3.1
- 1:2.10.9-0ubuntu3.2
- Affected ranges
- ECOSYSTEM: < 1:2.10.9-0ubuntu3.3
Update to 1:2.10.9-0ubuntu3.3
pidgin Ubuntu:16.04:LTS
- Versions
- 1:2.10.11-0ubuntu4
- 1:2.10.11-0ubuntu5
- 1:2.10.12-0ubuntu1
- 1:2.10.12-0ubuntu2
- 1:2.10.12-0ubuntu3
- 1:2.10.12-0ubuntu4
- 1:2.10.12-0ubuntu5
- Affected ranges
- ECOSYSTEM: < 1:2.10.12-0ubuntu5.1
Update to 1:2.10.12-0ubuntu5.1
Original sources
- http://www.securityfocus.com/bid/91335
- http://www.talosintelligence.com/reports/TALOS-2016-0142/
- http://www.debian.org/security/2016/dsa-3620
- http://www.pidgin.im/news/security/?id=107
- https://security.gentoo.org/glsa/201701-38
- http://www.ubuntu.com/usn/USN-3031-1
- https://nvd.nist.gov/vuln/detail/CVE-2016-2374