p PatchFirst

CVE-2016-2378

CVE-2016-2378

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A buffer overflow vulnerability exists in the handling of the MXIT protocol Pidgin. Specially crafted data sent via the server could potentially result in a buffer overflow, potentially resulting in memory corruption. A malicious server or an unfiltered malicious user can send negative length values to trigger this vulnerability.

CVSS 8.1 · High · EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • pidgin

    Versions
    • 2.10.11: Affected

    No fix published

  • pidgin Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

  • pidgin Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

  • pidgin Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.11.0-1

    Update to 2.11.0-1

  • pidgin Ubuntu:14.04:LTS

    Versions
    • 1:2.10.7-0ubuntu4.1
    • 1:2.10.7-0ubuntu4.2
    • 1:2.10.9-0ubuntu1
    • 1:2.10.9-0ubuntu2
    • 1:2.10.9-0ubuntu3
    • 1:2.10.9-0ubuntu3.1
    • 1:2.10.9-0ubuntu3.2
    Affected ranges
    • ECOSYSTEM: < 1:2.10.9-0ubuntu3.3

    Update to 1:2.10.9-0ubuntu3.3

  • pidgin Ubuntu:16.04:LTS

    Versions
    • 1:2.10.11-0ubuntu4
    • 1:2.10.11-0ubuntu5
    • 1:2.10.12-0ubuntu1
    • 1:2.10.12-0ubuntu2
    • 1:2.10.12-0ubuntu3
    • 1:2.10.12-0ubuntu4
    • 1:2.10.12-0ubuntu5
    Affected ranges
    • ECOSYSTEM: < 1:2.10.12-0ubuntu5.1

    Update to 1:2.10.12-0ubuntu5.1

Original sources

Check your server →