p PatchFirst

CVE-2016-2532

CVE-2016-2532

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The dissect_llrp_parameters function in epan/dissectors/packet-llrp.c in the LLRP dissector in Wireshark 1.12.x before 1.12.10 and 2.0.x before 2.0.2 does not limit the recursion depth, which allows remote attackers to cause a denial of service (memory consumption or application crash) via a crafted packet.

CVSS 5.9 · Medium · EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.2+ga16e22e-1

    Update to 2.0.2+ga16e22e-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.2+ga16e22e-1

    Update to 2.0.2+ga16e22e-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.2+ga16e22e-1

    Update to 2.0.2+ga16e22e-1

  • wireshark Ubuntu:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    • 1.10.6-1
    Affected ranges
    • ECOSYSTEM: < 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1

    Update to 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1

Original sources

Check your server →