CVE-2016-2814
CVE-2016-2814
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based buffer overflow in the stagefright::SampleTable::parseSampleCencInfo function in libstagefright in Mozilla Firefox before 46.0, Firefox ESR 38.x before 38.8, and Firefox ESR 45.x before 45.1 allows remote attackers to execute arbitrary code via crafted CENC offsets that lead to mismanagement of the sizes table.
CVSS 8.8 · High · EPSS 3.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 45.1.0esr-1
Update to 45.1.0esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 45.1.0esr-1
Update to 45.1.0esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 45.1.0esr-1
Update to 45.1.0esr-1
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- 45.0+build2-0ubuntu0.14.04.1
- 45.0.1+build1-0ubuntu0.14.04.2
- 45.0.2+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 46.0+build5-0ubuntu0.14.04.2
Update to 46.0+build5-0ubuntu0.14.04.2
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 46.0+build5-0ubuntu0.16.04.2
Update to 46.0+build5-0ubuntu0.16.04.2
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00005.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://rhn.redhat.com/errata/RHSA-2016-0695.html
- http://www.securitytracker.com/id/1035692
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00057.html
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00038.html
- http://www.ubuntu.com/usn/USN-2936-2
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00054.html
- https://security.gentoo.org/glsa/201701-15
- http://www.mozilla.org/security/announce/2016/mfsa2016-44.html
- http://www.debian.org/security/2016/dsa-3559
- http://www.ubuntu.com/usn/USN-2936-1
- http://www.ubuntu.com/usn/USN-2936-3
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00023.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1254721
- https://nvd.nist.gov/vuln/detail/CVE-2016-2814