CVE-2016-3076
CVE-2016-3076
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based buffer overflow in the j2k_encode_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted Jpeg2000 file.
CVSS 7.1 · High · EPSS 2.6% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
pillow Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.0-1
Update to 3.2.0-1
pillow Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.0-1
Update to 3.2.0-1
pillow Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.0-1
Update to 3.2.0-1
pillow PyPI
- Versions
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 3.0.0
- 3.1.0
- 3.1.0.rc1
- 3.1.0rc1
- 3.1.1
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 3.1.2
Update to 3.1.2