p PatchFirst

CVE-2016-3132

CVE-2016-3132

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Double free vulnerability in the SplDoublyLinkedList::offsetSet function in ext/spl/spl_dllist.c in PHP 7.x before 7.0.6 allows remote attackers to execute arbitrary code via a crafted index.

CVSS 9.8 · Critical · EPSS 11.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    Affected ranges
    • ECOSYSTEM: < 7.0.4-7ubuntu2.1

    Update to 7.0.4-7ubuntu2.1

Original sources

Check your server →