CVE-2016-3185
CVE-2016-3185
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The make_http_soap_request function in ext/soap/php_http.c in PHP before 5.4.44, 5.5.x before 5.5.28, 5.6.x before 5.6.12, and 7.x before 7.0.4 allows remote attackers to obtain sensitive information from process memory or cause a denial of service (type confusion and application crash) via crafted serialized _cookies data, related to the SoapClient::__call method in ext/soap/soap.c.
CVSS 7.1 · High · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php5 Ubuntu:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- 5.5.9+dfsg-1ubuntu4.11
- 5.5.9+dfsg-1ubuntu4.12
- 5.5.9+dfsg-1ubuntu4.13
- 5.5.9+dfsg-1ubuntu4.14
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.16
Update to 5.5.9+dfsg-1ubuntu4.16
Original sources
- https://bugs.php.net/bug.php?id=71610
- http://www.ubuntu.com/usn/USN-2952-1
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00056.html
- http://www.ubuntu.com/usn/USN-2952-2
- http://php.net/ChangeLog-5.php
- http://www.securityfocus.com/bid/84307
- https://git.php.net/?p=php-src.git%3Ba=commit%3Bh=eaf4e77190d402ea014207e9a7d5da1a4f3727ba
- http://php.net/ChangeLog-7.php
- https://bugs.php.net/bug.php?id=70081
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00052.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-3185