CVE-2016-3714
CVE-2016-3714
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allow remote attackers to execute arbitrary code via shell metacharacters in a crafted image, aka "ImageTragick."
CVSS 8.4 · High · EPSS 97.5% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
graphicsmagick Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.24-1
Update to 1.3.24-1
graphicsmagick Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.24-1
Update to 1.3.24-1
graphicsmagick Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.24-1
Update to 1.3.24-1
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
graphicsmagick Ubuntu:14.04:LTS
- Versions
- 1.3.16-1.1ubuntu2
- 1.3.16-1.1ubuntu3
- 1.3.18-1ubuntu3
- Affected ranges
- ECOSYSTEM: < 1.3.18-1ubuntu3.1
Update to 1.3.18-1ubuntu3.1
imagemagick Ubuntu:14.04:LTS
- Versions
- 8:6.7.7.10-5ubuntu3
- 8:6.7.7.10-5ubuntu4
- 8:6.7.7.10-6ubuntu1
- 8:6.7.7.10-6ubuntu2
- 8:6.7.7.10-6ubuntu3
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.1
Update to 8:6.7.7.10-6ubuntu3.1
graphicsmagick Ubuntu:16.04:LTS
- Versions
- 1.3.21-3
- 1.3.23-1
- 1.3.23-1build1
- Affected ranges
- ECOSYSTEM: < 1.3.23-1ubuntu0.1
Update to 1.3.23-1ubuntu0.1
imagemagick Ubuntu:16.04:LTS
- Versions
- 8:6.8.9.9-5ubuntu2
- 8:6.8.9.9-6
- 8:6.8.9.9-6build1
- 8:6.8.9.9-7
- 8:6.8.9.9-7ubuntu1
- 8:6.8.9.9-7ubuntu2
- 8:6.8.9.9-7ubuntu3
- 8:6.8.9.9-7ubuntu4
- 8:6.8.9.9-7ubuntu5
- Affected ranges
- ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.1
Update to 8:6.8.9.9-7ubuntu5.1
Original sources
- https://access.redhat.com/security/vulnerabilities/2296071
- http://git.imagemagick.org/repos/ImageMagick/blob/a01518e08c840577cabd7d3ff291a9ba735f7276/ChangeLog
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00028.html
- http://www.securitytracker.com/id/1035742
- https://imagetragick.com/
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- https://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=29588
- http://www.openwall.com/lists/oss-security/2016/05/03/13
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00051.html
- http://www.ubuntu.com/usn/USN-2990-1
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00025.html
- http://www.securityfocus.com/archive/1/538378/100/0/threaded
- https://www.exploit-db.com/exploits/39767/
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00024.html
- http://www.rapid7.com/db/modules/exploit/unix/fileformat/imagemagick_delegate
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.openwall.com/lists/oss-security/2016/05/03/18
- http://www.debian.org/security/2016/dsa-3746
- https://security.gentoo.org/glsa/201611-21
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00032.html
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.440568
- https://www.imagemagick.org/script/changelog.php
- https://nvd.nist.gov/vuln/detail/CVE-2016-3714