CVE-2016-4417
CVE-2016-4417
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Off-by-one error in epan/dissectors/packet-gsm_abis_oml.c in the GSM A-bis OML dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers a 0xff tag value.
CVSS 5.9 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.2+ga16e22e-1
Update to 2.0.2+ga16e22e-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.2+ga16e22e-1
Update to 2.0.2+ga16e22e-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.2+ga16e22e-1
Update to 2.0.2+ga16e22e-1
wireshark Ubuntu:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu14.04.1
Update to 2.6.3-1~ubuntu14.04.1
wireshark Ubuntu:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- 2.2.6+g32dac6a-2ubuntu0.16.04
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu16.04.1
Update to 2.6.3-1~ubuntu16.04.1
wireshark Ubuntu:18.04:LTS
- Versions
- 2.4.2-1
- 2.4.3-1
- 2.4.4-1
- 2.4.5-1
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu18.04.1
Update to 2.6.3-1~ubuntu18.04.1
Original sources
- http://lists.opensuse.org/opensuse-updates/2016-03/msg00016.html
- https://www.wireshark.org/security/wnpa-sec-2016-14.html
- http://lists.opensuse.org/opensuse-updates/2016-03/msg00015.html
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11825
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-4417