p PatchFirst

CVE-2016-4428

CVE-2016-4428

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.

CVSS 5.4 · Medium · EPSS 2.1% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • horizon Debian:12

    Affected ranges
    • ECOSYSTEM: < 3:9.0.1-2

    Update to 3:9.0.1-2

  • horizon Debian:13

    Affected ranges
    • ECOSYSTEM: < 3:9.0.1-2

    Update to 3:9.0.1-2

  • horizon Debian:14

    Affected ranges
    • ECOSYSTEM: < 3:9.0.1-2

    Update to 3:9.0.1-2

  • horizon PyPI

    Affected ranges
    • ECOSYSTEM: < 8.0.2

    Update to 8.0.2

  • horizon PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 9.0.0, < 9.1.0

    Update to 9.1.0

  • horizon PyPI

    Affected ranges
    • ECOSYSTEM: < 8.0.2 ∪ ≥ 9.0.0, < 9.1.0

    Update to 8.0.2; Update to 9.1.0

  • horizon Ubuntu:14.04:LTS

    Versions
    • 1:2013.2~rc3-0ubuntu1
    • 1:2013.2-0ubuntu1
    • 1:2014.1~b1-0ubuntu1
    • 1:2014.1~b2-0ubuntu1
    • 1:2014.1~b2-0ubuntu2
    • 1:2014.1~b3-0ubuntu1
    • 1:2014.1~b3-0ubuntu2
    • 1:2014.1~rc1-0ubuntu1
    • 1:2014.1~rc2-0ubuntu1
    • 1:2014.1-0ubuntu1
    • 1:2014.1.1-0ubuntu1
    • 1:2014.1.2-0ubuntu1
    • 1:2014.1.2-0ubuntu1.1
    • 1:2014.1.3-0ubuntu1
    • 1:2014.1.3-0ubuntu2
    • 1:2014.1.4-0ubuntu2
    • 1:2014.1.5-0ubuntu1
    • 1:2014.1.5-0ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1:2014.1.5-0ubuntu2.1

    Update to 1:2014.1.5-0ubuntu2.1

Original sources

Check your server →