CVE-2016-4952
CVE-2016-4952
This page contains facts from public vulnerability sources. Check the original advisory before updating.
QEMU (aka Quick Emulator), when built with VMWARE PVSCSI paravirtual SCSI bus emulation support, allows local guest OS administrators to cause a denial of service (out-of-bounds array access) via vectors related to the (1) PVSCSI_CMD_SETUP_RINGS or (2) PVSCSI_CMD_SETUP_MSG_RING SCSI command.
CVSS 6.0 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-2
Update to 1:2.6+dfsg-2
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-2
Update to 1:2.6+dfsg-2
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.6+dfsg-2
Update to 1:2.6+dfsg-2
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- 2.0.0+dfsg-2ubuntu1.13
- 2.0.0+dfsg-2ubuntu1.14
- 2.0.0+dfsg-2ubuntu1.15
- 2.0.0+dfsg-2ubuntu1.16
- 2.0.0+dfsg-2ubuntu1.17
- 2.0.0+dfsg-2ubuntu1.18
- 2.0.0+dfsg-2ubuntu1.19
- 2.0.0+dfsg-2ubuntu1.20
- 2.0.0+dfsg-2ubuntu1.21
- 2.0.0+dfsg-2ubuntu1.22
- 2.0.0+dfsg-2ubuntu1.24
- 2.0.0+dfsg-2ubuntu1.25
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.26
Update to 2.0.0+dfsg-2ubuntu1.26
qemu Ubuntu:16.04:LTS
- Versions
- 1:2.3+dfsg-5ubuntu9
- 1:2.3+dfsg-5ubuntu10
- 1:2.4+dfsg-4ubuntu1
- 1:2.4+dfsg-4ubuntu2
- 1:2.4+dfsg-4ubuntu3
- 1:2.4+dfsg-5ubuntu3
- 1:2.5+dfsg-1ubuntu2
- 1:2.5+dfsg-1ubuntu3
- 1:2.5+dfsg-1ubuntu4
- 1:2.5+dfsg-1ubuntu5
- 1:2.5+dfsg-5ubuntu1
- 1:2.5+dfsg-5ubuntu2
- 1:2.5+dfsg-5ubuntu4
- 1:2.5+dfsg-5ubuntu6
- 1:2.5+dfsg-5ubuntu7
- 1:2.5+dfsg-5ubuntu10
- 1:2.5+dfsg-5ubuntu10.1
- 1:2.5+dfsg-5ubuntu10.2
- Affected ranges
- ECOSYSTEM: < 1:2.5+dfsg-5ubuntu10.3
Update to 1:2.5+dfsg-5ubuntu10.3
Original sources
- http://www.ubuntu.com/usn/USN-3047-1
- http://www.openwall.com/lists/oss-security/2016/05/23/1
- http://www.openwall.com/lists/oss-security/2016/05/23/4
- https://lists.gnu.org/archive/html/qemu-devel/2016-05/msg03774.html
- http://www.ubuntu.com/usn/USN-3047-2
- https://bugzilla.redhat.com/show_bug.cgi?id=1334384
- https://lists.debian.org/debian-lts-announce/2018/11/msg00038.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-4952