CVE-2016-4994
CVE-2016-4994
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Use-after-free vulnerability in the xcf_load_image function in app/xcf/xcf-load.c in GIMP allows remote attackers to cause a denial of service (program crash) or possibly execute arbitrary code via a crafted XCF file.
CVSS 7.8 · High · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gimp Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.16-2.2
Update to 2.8.16-2.2
gimp Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.16-2.2
Update to 2.8.16-2.2
gimp Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.16-2.2
Update to 2.8.16-2.2
gimp Ubuntu:14.04:LTS
- Versions
- 2.8.6-1ubuntu1
- 2.8.6-1ubuntu2
- 2.8.6-1ubuntu3
- 2.8.10-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.8.10-0ubuntu1.1
Update to 2.8.10-0ubuntu1.1
gimp Ubuntu:16.04:LTS
- Versions
- 2.8.14-1ubuntu2
- 2.8.14-1.2ubuntu1
- 2.8.16-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.8.16-1ubuntu1.1
Update to 2.8.16-1ubuntu1.1
Original sources
- http://www.securitytracker.com/id/1036226
- https://git.gnome.org/browse/gimp/commit/?id=e82aaa4b4ee0703c879e35ea9321fff6be3e9b6f
- https://bugzilla.gnome.org/show_bug.cgi?id=767873
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00005.html
- http://www.securityfocus.com/bid/91425
- http://www.debian.org/security/2016/dsa-3612
- http://www.ubuntu.com/usn/USN-3025-1
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.431987
- http://rhn.redhat.com/errata/RHSA-2016-2589.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-4994