CVE-2016-5008
CVE-2016-5008
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libvirt before 2.0.0 improperly disables password checking when the password on a VNC server is set to an empty string, which allows remote attackers to bypass authentication and establish a VNC session by connecting to the server.
CVSS 9.8 · Critical · EPSS 3.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvirt Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.0-1
Update to 2.0.0-1
libvirt Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.0-1
Update to 2.0.0-1
libvirt Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.0-1
Update to 2.0.0-1
libvirt Ubuntu:14.04:LTS
- Versions
- 1.1.1-0ubuntu8
- 1.1.1-0ubuntu9
- 1.1.4-0ubuntu2
- 1.1.4-0ubuntu3
- 1.1.4-0ubuntu4
- 1.1.4-0ubuntu5
- 1.2.0-0ubuntu1
- 1.2.0-0ubuntu2
- 1.2.0-0ubuntu3
- 1.2.1-0ubuntu1
- 1.2.1-0ubuntu2
- 1.2.1-0ubuntu3
- 1.2.1-0ubuntu4
- 1.2.1-0ubuntu5
- 1.2.1-0ubuntu7
- 1.2.1-0ubuntu8
- 1.2.1-0ubuntu9
- 1.2.1-0ubuntu10
- 1.2.2-0ubuntu1
- 1.2.2-0ubuntu2
- 1.2.2-0ubuntu3
- 1.2.2-0ubuntu4
- 1.2.2-0ubuntu5
- 1.2.2-0ubuntu6
- 1.2.2-0ubuntu7
- 1.2.2-0ubuntu8
- 1.2.2-0ubuntu9
- 1.2.2-0ubuntu10
- 1.2.2-0ubuntu11
- 1.2.2-0ubuntu12
- 1.2.2-0ubuntu13
- 1.2.2-0ubuntu13.1
- 1.2.2-0ubuntu13.1.1
- 1.2.2-0ubuntu13.1.2
- 1.2.2-0ubuntu13.1.4
- 1.2.2-0ubuntu13.1.5
- 1.2.2-0ubuntu13.1.6
- 1.2.2-0ubuntu13.1.7
- 1.2.2-0ubuntu13.1.8
- 1.2.2-0ubuntu13.1.9
- 1.2.2-0ubuntu13.1.10
- 1.2.2-0ubuntu13.1.12
- 1.2.2-0ubuntu13.1.14
- 1.2.2-0ubuntu13.1.16
- 1.2.2-0ubuntu13.1.17
- 1.2.2-0ubuntu13.1.20
- 1.2.2-0ubuntu13.1.21
- 1.2.2-0ubuntu13.1.22
- 1.2.2-0ubuntu13.1.23
- 1.2.2-0ubuntu13.1.25
- Affected ranges
- ECOSYSTEM: < 1.2.2-0ubuntu13.1.26
Update to 1.2.2-0ubuntu13.1.26
libvirt Ubuntu:16.04:LTS
- Versions
- 1.2.16-2ubuntu11
- 1.2.16-2ubuntu12
- 1.2.16-2ubuntu13
- 1.2.16-2ubuntu14
- 1.2.21-2ubuntu1
- 1.2.21-2ubuntu3
- 1.2.21-2ubuntu4
- 1.2.21-2ubuntu5
- 1.2.21-2ubuntu7
- 1.2.21-2ubuntu8
- 1.2.21-2ubuntu9
- 1.2.21-2ubuntu10
- 1.3.1-1ubuntu1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu3
- 1.3.1-1ubuntu4
- 1.3.1-1ubuntu6
- 1.3.1-1ubuntu9
- 1.3.1-1ubuntu10
- 1.3.1-1ubuntu10.1
- 1.3.1-1ubuntu10.2
- 1.3.1-1ubuntu10.3
- 1.3.1-1ubuntu10.5
- 1.3.1-1ubuntu10.6
- 1.3.1-1ubuntu10.7
- 1.3.1-1ubuntu10.8
- 1.3.1-1ubuntu10.10
- 1.3.1-1ubuntu10.11
- 1.3.1-1ubuntu10.12
- 1.3.1-1ubuntu10.13
- 1.3.1-1ubuntu10.14
- 1.3.1-1ubuntu10.15
- 1.3.1-1ubuntu10.17
- 1.3.1-1ubuntu10.18
- Affected ranges
- ECOSYSTEM: < 1.3.1-1ubuntu10.19
Update to 1.3.1-1ubuntu10.19
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1180092
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DZZMOMRXNPALA34XDF5NK363KDLAYSTL/
- http://www.debian.org/security/2016/dsa-3613
- http://www.securityfocus.com/bid/91562
- http://security.libvirt.org/2016/0001.html
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00055.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QTQF6LXKEEMJG4VOOCIAPJAD6ACBYP4W/
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00024.html
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00054.html
- http://rhn.redhat.com/errata/RHSA-2016-2577.html
- https://usn.ubuntu.com/3576-1/
- https://nvd.nist.gov/vuln/detail/CVE-2016-5008