p PatchFirst

CVE-2016-5108

CVE-2016-5108

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

CVSS 9.8 · Critical · EPSS 24.7% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • vlc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

  • vlc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

  • vlc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

  • vlc Ubuntu:14.04:LTS

    Versions
    • 2.0.8-1
    • 2.1.1-1
    • 2.1.2-1
    • 2.1.2-2
    • 2.1.2-2build1
    • 2.1.2-2build2
    • 2.1.4-0ubuntu14.04.1
    • 2.1.6-0ubuntu14.04.1
    • 2.1.6-0ubuntu14.04.2
    Affected ranges
    • ECOSYSTEM: < 2.1.6-0ubuntu14.04.3

    Update to 2.1.6-0ubuntu14.04.3

  • vlc Ubuntu:16.04:LTS

    Versions
    • 2.2.1-3
    • 2.2.1-5
    • 2.2.2-1
    • 2.2.2-2
    • 2.2.2-3
    • 2.2.2-3build1
    • 2.2.2-4
    • 2.2.2-5
    • 2.2.2-5ubuntu0.16.04.1
    • 2.2.2-5ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: < 2.2.2-5ubuntu0.16.04.3

    Update to 2.2.2-5ubuntu0.16.04.3

Original sources

Check your server →