p PatchFirst

CVE-2016-5118

CVE-2016-5118

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The OpenBlob function in blob.c in GraphicsMagick before 1.3.24 and ImageMagick allows remote attackers to execute arbitrary code via a | (pipe) character at the start of a filename.

CVSS 9.8 · Critical · EPSS 50.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • graphicsmagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • graphicsmagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • graphicsmagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.24-1

    Update to 1.3.24-1

  • imagemagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 8:6.8.9.9-7.1

    Update to 8:6.8.9.9-7.1

  • imagemagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 8:6.8.9.9-7.1

    Update to 8:6.8.9.9-7.1

  • imagemagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 8:6.8.9.9-7.1

    Update to 8:6.8.9.9-7.1

  • graphicsmagick Ubuntu:14.04:LTS

    Versions
    • 1.3.16-1.1ubuntu2
    • 1.3.16-1.1ubuntu3
    • 1.3.18-1ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.3.18-1ubuntu3.1

    Update to 1.3.18-1ubuntu3.1

  • imagemagick Ubuntu:14.04:LTS

    Versions
    • 8:6.7.7.10-5ubuntu3
    • 8:6.7.7.10-5ubuntu4
    • 8:6.7.7.10-6ubuntu1
    • 8:6.7.7.10-6ubuntu2
    • 8:6.7.7.10-6ubuntu3
    Affected ranges
    • ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.1

    Update to 8:6.7.7.10-6ubuntu3.1

  • graphicsmagick Ubuntu:16.04:LTS

    Versions
    • 1.3.21-3
    • 1.3.23-1
    • 1.3.23-1build1
    Affected ranges
    • ECOSYSTEM: < 1.3.23-1ubuntu0.1

    Update to 1.3.23-1ubuntu0.1

  • imagemagick Ubuntu:16.04:LTS

    Versions
    • 8:6.8.9.9-5ubuntu2
    • 8:6.8.9.9-6
    • 8:6.8.9.9-6build1
    • 8:6.8.9.9-7
    • 8:6.8.9.9-7ubuntu1
    • 8:6.8.9.9-7ubuntu2
    • 8:6.8.9.9-7ubuntu3
    • 8:6.8.9.9-7ubuntu4
    • 8:6.8.9.9-7ubuntu5
    Affected ranges
    • ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.1

    Update to 8:6.8.9.9-7ubuntu5.1

Original sources

Check your server →