CVE-2016-5159
CVE-2016-5159
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer overflows in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data that is mishandled during opj_aligned_malloc calls in dwt.c and t1.c.
CVSS 8.8 · High · EPSS 2.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
openjpeg2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.1.2-1
Update to 2.1.2-1
openjpeg2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.1.2-1
Update to 2.1.2-1
openjpeg2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.1.2-1
Update to 2.1.2-1
chromium-browser Ubuntu:14.04:LTS
- Versions
- 29.0.1547.65-0ubuntu2
- 31.0.1650.63-0ubuntu1~20131204.1
- 32.0.1700.107-0ubuntu1~20140204.977.1
- 33.0.1750.152-0ubuntu1~pkg995.1
- 34.0.1847.116-0ubuntu2
- 36.0.1985.125-0ubuntu1.14.04.0~pkg1029
- 37.0.2062.94-0ubuntu0.14.04.1~pkg1042
- 37.0.2062.120-0ubuntu0.14.04.1~pkg1049
- 38.0.2125.111-0ubuntu0.14.04.1.1061
- 39.0.2171.65-0ubuntu0.14.04.1.1064
- 40.0.2214.94-0ubuntu0.14.04.1.1068
- 40.0.2214.111-0ubuntu0.14.04.1.1069
- 41.0.2272.76-0ubuntu0.14.04.1.1076
- 43.0.2357.81-0ubuntu0.14.04.1.1089
- 43.0.2357.130-0ubuntu0.14.04.1.1092
- 44.0.2403.89-0ubuntu0.14.04.1.1095
- 45.0.2454.85-0ubuntu0.14.04.1.1097
- 45.0.2454.101-0ubuntu0.14.04.1.1099
- 47.0.2526.73-0ubuntu0.14.04.1.1106
- 47.0.2526.106-0ubuntu0.14.04.1.1107
- 48.0.2564.82-0ubuntu0.14.04.1.1108
- 48.0.2564.116-0ubuntu0.14.04.1.1111
- 49.0.2623.87-0ubuntu0.14.04.1.1112
- 49.0.2623.108-0ubuntu0.14.04.1.1113
- 50.0.2661.102-0ubuntu0.14.04.1.1117
- 51.0.2704.79-0ubuntu0.14.04.1.1121
- 52.0.2743.116-0ubuntu0.14.04.1.1134
- Affected ranges
- ECOSYSTEM: < 53.0.2785.143-0ubuntu0.14.04.1.1142
Update to 53.0.2785.143-0ubuntu0.14.04.1.1142
chromium-browser Ubuntu:16.04:LTS
- Versions
- 45.0.2454.101-0ubuntu1.1201
- 47.0.2526.73-0ubuntu1.1218
- 47.0.2526.106-0ubuntu1.1221
- 48.0.2564.82-0ubuntu1.1222
- 48.0.2564.116-0ubuntu1.1229
- 49.0.2623.87-0ubuntu1.1232
- 49.0.2623.108-0ubuntu1.1233
- 50.0.2661.102-0ubuntu0.16.04.1.1237
- 51.0.2704.79-0ubuntu0.16.04.1.1242
- 52.0.2743.116-0ubuntu0.16.04.1.1250
- Affected ranges
- ECOSYSTEM: < 53.0.2785.143-0ubuntu0.16.04.1.1254
Update to 53.0.2785.143-0ubuntu0.16.04.1.1254
openjpeg2 Ubuntu:16.04:LTS
- Versions
- 2.1.0-2.1
- 2.1.0-2.1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.1.2-1.1+deb9u2build0.1
Update to 2.1.2-1.1+deb9u2build0.1
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00003.html
- https://googlechromereleases.blogspot.com/2016/08/stable-channel-update-for-desktop_31.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00004.html
- http://www.securityfocus.com/bid/92717
- http://www.securitytracker.com/id/1036729
- http://rhn.redhat.com/errata/RHSA-2017-0559.html
- http://rhn.redhat.com/errata/RHSA-2017-0838.html
- http://lists.opensuse.org/opensuse-updates/2016-09/msg00073.html
- http://www.debian.org/security/2017/dsa-3768
- https://crbug.com/628304
- http://www.debian.org/security/2016/dsa-3660
- https://security.gentoo.org/glsa/201610-09
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00008.html
- http://rhn.redhat.com/errata/RHSA-2016-1854.html
- https://codereview.chromium.org/2218783002/
- https://nvd.nist.gov/vuln/detail/CVE-2016-5159